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Chapter 1

OctaMED

1.1 Loading, Saving, Printing / Working With Files

HOW TO...

Use the ASL file requester

Replace ASL with ReqTools

Delete one or more files

Open an AmigaDOS shell
OVERVIEW

Loosely speaking, a file is anything that can be stored on disk. In
OctaMED, it can be a song, instrument, MIDI message, text file and
so on.

Before a file can be loaded, saved or deleted, it must be selected.
That is, you must tell OctaMED which file is to be loaded, saved or
deleted. In common with most Amiga programs, this is done using the
ASL file requester. If you wish, you can replace ASL with the
arguably more powerful ReqTools by Nico François.

Delete (remove from disk) one or more files, or open an AmigaDOS
shell for full control over your files, through the Project menu.

NOTES

* OctaMED provides a safeguard against accidental file deletion.
In saving operations, if you select a file that already exists
(i.e. the file is to be saved over), a requester appears
confirming that you really want to overwrite the file.

Experienced users can find this irritating; if you fall into this
category, switch off Overwrite Requesters in the Miscellaneous Where?
Options window.

1.2 Working With Files / How To Use The ASL File Requester
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HOW TO USE THE ASL FILE REQUESTER
INTRODUCTION
Before a file can be loaded, saved or deleted, it must be selected.
That is, you must tell OctaMED which file is to be loaded, saved or
deleted. In common with most Amiga programs, this is done using the
ASL file requester.

In order to locate a file, you must specify the disk (or ‘volume’)
on which it is stored, the directory (or ‘drawer’) in which it
resides, and finally its filename. The combination of disk and
directory name is called the file’s ‘path’; that is, where to look
for the file.

When the file requester first appears, it loads the contents of a
directory and displays it. By default, the directory is that in
which the OctaMED program resides. You can change to the correct
directory and select a file by typing their names into Drawer and
File respectively. Alternatively, click on file or directory names
in the list, and use the Volumes and Parent buttons.

The how-to assumes that a file requester is already displayed, as a
result of a load, save or deletion operation.

STEPS
1) If necessary, change the disk name.

> Click Volumes (bottom) THEN
> Choose a disk or ‘logical assignment’ from the list

* If you click Volumes by mistake, click it again to return to
the directory contents.

2) If necessary, change the directory.
> Click on a directory in the list OR
> Type a directory name into the Drawer box

3) EITHER Select one file.
> Double-click on a file in the list OR
> Click on a file in the list, then click OK OR
> Type a filename into the File box and press Return

OR If possible, select many files.
> Keep the Shift key held down THEN
> Click on the desired files in the list THEN
> Click OK

NOTES

* If some of the files or directories in the list are not shown,
drag the scroll bar along the right to reveal them.

* In saving operations, the file cannot be selected by double-
clicking on it (in step 3). This is a safeguard against
accidental file removal.

* Sometimes the file requester doesn’t show files, only directories
(especially with the Sample List Editor). In this case you can

More
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call it a directory requester.

* The ASL file requester has a Control menu, which can occasionally
be useful (try its keyboard shortcuts).

1.3 Working With Files / How To Replace ASL With ReqTools

HOW TO REPLACE ASL WITH REQTOOLS
INTRODUCTION
Although ASL is the Amiga’s ‘standard’ requester system, OctaMED
can optionally use Nico François’ ReqTools system. An especially
useful feature of ReqTools’ file requester is its automatic
filename sorter.

STEPS
1) Ensure that reqtools.library is in the LIBS: directory.

2) Open the Miscellaneous Options window.
> Settings menu -> Miscellaneous

3) Use the ReqTools system.
> Switch on Use ReqTools (left-hand side)

NOTES

* File, system, screen mode and font requesters are all part of the
ReqTools system.

* Some other file requesters use a ‘patch’ system to automatically
replace ASL when activated. One such requester is the Magic File
Requester. To use such file requesters, keep Use ReqTools
switched off and install the file requester as explained in its
documentation.

1.4 Working With Files / How To Delete One Or More Files

HOW TO DELETE ONE OR MORE FILES
INTRODUCTION
If you have no further use for one or more files in a directory,
use Delete Files in the Project menu to remove them from disk.

STEPS
1) Open the Delete Files file requester.

> Project menu -> Delete Files

2) Select one or more files in the file requester.
How?

NOTES

* If the file is an instrument in your sample list, you can delete
How?
the instrument *and* remove its name from the sample list in one

go.
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1.5 Working With Files / How To Open An AmigaDOS Shell

HOW TO OPEN AN AMIGADOS SHELL
INTRODUCTION
For full control over your files, you can open a shell and
manipulate files using AmigaDOS commands.

STEPS
1) Open an AmigaDOS shell.

> Project menu -> AmigaDOS Shell

NOTES

* Another way to run a program is to set up an appropriate keyboard More
shortcut, input map or player command, using the Launch Program
option in the Action area.

1.6 Loading, Saving, Printing / Songs

HOW TO...

Load a song

Load a Standard MIDI File

Save a song

Set song compression options

Attach a message to a song

Set the save timer
OVERVIEW

Rather than write a song from scratch, you can load a song from
disk into OctaMED for playing or editing. And there’s no point in
creating a masterpiece if it can’t be saved to disk!

OctaMED, of course, can load any song composed in OctaMED, but it
can also load songs of other formats. A particularly useful format
is the Standard MIDI File; almost all MIDI sequencers save their
songs in this format. Songs can be saved in Standard MIDI File
format type 0, or as executable files to run and listen to.

To save disk space, your song can be compressed in one of several
formats. A message, or ‘annotation text’, can easily be attached to
your song before saving. Finally, to prevent grief resulting from
lost songs, OctaMED can save your song automatically every few
minutes.

1.7 Songs / How To Load A Song

HOW TO LOAD A SONG
INTRODUCTION
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Rather than write a song from scratch, you can load a song from
disk into OctaMED for playing or editing. OctaMED opens a file
requester with which you select the song to load. If there is
already a song in memory that has not been saved, OctaMED offers to
save it first.

OctaMED, of course, can load any song composed in OctaMED, but it
can also load songs of other formats. Refer to the ALSO SEE section
below for a list of recognised song formats.

Some songs created in OctaMED are saved without their instruments;
only the instrument names are saved. When loading such songs,
OctaMED looks up each instrument name in the sample list to
determine the disk and directory containing the instrument. OctaMED
then loads the instruments from these locations. A requester
appears if any of these instruments cannot be found.

By default, the directory initially loaded into the file requester
is the directory containing the OctaMED program. If you have a
favourite directory for storing songs, type its path into the Songs
box in the Default Directories window. Where?

STEPS
1) Open the Open Song/Module file requester.

> Project menu -> Open

2) Select a song to load.
How?

NOTES

* After loading, the song’s one-line message (if set) appears on
More
the title bar. Optionally, the Song Annotation window opens if

annotation text is set.

* To start the song playing automatically after loading, switch on
Project menu -> Play After Loading. This is particularly useful
when you’re trying out all the songs on a song compilation disk.

* After loading, songs can be converted from the old playing modes More
to the new Mix mode. To convert songs created in OctaMED, switch
on Use Mixing (MMD) in Miscellaneous Options. To convert songs Where?
created in Tracker clones, switch on Use Mixing (Tracker). Where?

* Songs written in OctaMED version 3 or 4, in 5 to 8-channel mode More
with High Quality Mode on, will play too quickly. This is because
in those versions, switching on High Quality Mode slowed the song
tempo, so composers compensated by quickening the speed.

To play such songs at their intended speed, switch on Slow HQ in
the Tempo window. Slow HQ can be switched on automatically at
startup: Set Default Slow HQ Mode (Miscellaneous Options window) Where?
to On, then save settings.

How?

* Tracker clones handle pitch slides in a slightly different way
from OctaMED. To allow for this, loading a song written with a
Tracker clone switches on No Slide On 1st Tick (Song Options).
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* Instrument names in songs composed in Tracker clones often
include their full path. To automatically remove the full path
names, switch on Instr menu -> Remove Path.

ALSO SEE
Song File Formats

How To Load A Standard MIDI File

1.8 Songs / How To Load A Standard Midi File

HOW TO LOAD A STANDARD MIDI FILE
INTRODUCTION
OctaMED is not restricted to loading songs created by itself. A
particularly useful song format recognised is the Standard MIDI
File (SMF). Almost all MIDI sequencers save their songs in this
format. OctaMED recognises type 0 and 1 SMFs (and can also save

More
type 0 SMFs).

Because SMFs are radically different from OctaMED songs, it’s
possible that the song is not loaded correctly at first. For this
reason, OctaMED has a whole window devoted to loading options for
SMFs. If at first OctaMED doesn’t succeed, try adjusting some
options in this window.

STEPS
1) Open the Open Song/Module file requester.

> Project menu -> Open

2) Select a Standard MIDI File to load.
How?

3) If the file is not loaded successfully, open the SMF Load
Options window.
> MIDI menu -> SMF Load Options

4) If you’re getting ‘not enough memory’ reports, reduce the
maximum number of tracks.
> Type a new value into Max Tracks (top-left)

5) If timing is inaccurate, increase the ‘resolution’ (number of
Tracker editor lines per quarter note).
> Adjust the Resolution slider to perhaps 16 or 32

6) To adjust minor discrepancies in overall timing, change the
offset. For example, if the first block starts on line 001
instead of 000, set the offset to -1.
> Adjust the Offset Adjust slider

7) If player commands are cancelling each other out due to command
page conflicts, ensure that each player command type is placed
on a different page so that no commands overlap. (If the page is
0, the command is not loaded.)
> Set the eight boxes in the Command Pages area appropriately
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8) If notes of a type 1 SMF are frequently cut off prematurely,
prevent the interweaving of notes to use as few tracks as
possible.
> Switch on Don’t Intermix Type 1 Tracks

9) Close the window and go back to step 1.
> Click Exit

1.9 Songs / How To Save A Song

HOW TO SAVE A SONG
INTRODUCTION
During and after the composition of a song, save the song to disk.
Give the song a filename, and set any required save options, in the
Save Options window.

There are options to save ‘secondary’ information not actually
required to play the song successfully; to create a Workbench icon
for the song; to save information used by the notation editor; and
to save instrument names rather than instruments themselves, saving
disk space.

Other options set the song’s file format, save all songs or the
current song of a multi-module, and compress the song (again saving
disk space). Before saving, the size of the resulting file -
compressed or uncompressed - can be calculated.

STEPS
1) EITHER Select a filename in the file requester which appears

How?
automatically. This occurs if no filename is set.

OR If necessary, change the existing filename.
> Type a new name into the text box at the top OR
> Click on the GetFile gadget (top corner) and select a file

How?
2) Choose whether or not to save secondary information (see notes) ←↩

.
> Switch Save Secondary Data on or off

3) Choose whether or not to save an icon with the song (see notes).
> Switch Create Icon on or off

4) Choose whether or not to save notation information (see notes).
> Switch Save Notation Data on or off

5) Choose whether or not to save the instruments with the song. If
you choose not to, only the instrument names are saved. Upon
reloading the song, the sample list is used to load instruments

More
directly from your instrument disks.

> Switch Save Instruments on or off

6) If appropriate, choose whether to save the current song or all More
songs of a multi-module.
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> Set the cycle gadget to Save Multi-Module or Current Song Only

7) If desired, choose a file format. In most cases, the More
automatically-selected file format is suitable for your song.
> Click on one of the five file formats in the radio button

8) If desired, set song compression options.
How?

9) Save the song.
> Click Save

NOTES

* To calculate the size of the saved song file, click Calculate
Size or Packed (the latter calculates the size when compressed).

* Secondary data is: Instrument names, line highlighting, block
names, the song name (or names for a multi-module). Choosing not
to save this information makes the song a few bytes shorter.

* The icons used with Create Icon are contained in the
PROGDIR:Icons directory, where PROGDIR is the directory
containing the OctaMED program. Executable.info is the icon for
executable files, Module.info the icon for other files.

Feel free to replace these icons with your own. Module.info
should be a ‘project’ icon, Executable.info a ‘tool’ icon.

* The notation information saved is: Key and time signatures;
requested display width; number of staffs; number of measures
on-screen at once; Harmonic Minor Scale state; all information
in the Assign Tracks window. More

Also, for each staff, all information in the Staff Setup window More
is saved.

* OctaMED can warn you if the song probably won’t fit on the disk
on which it will be saved. (Switch on Warn if Disk Full in the Where?
Miscellaneous Options window.) It’s impossible to predict this
accurately, though, and the file may not fit even if the
requester does not appear.

Also, the requester always appears when saving to the RAM: disk
(because RAM: is always 100 % full!). Just ignore it.

* As mentioned, when songs saved without instruments are reloaded,
instruments are individually loaded using the sample list.
Instruments not occurring in the sample list can still be loaded
if their full paths are given with their names. Add full paths
automatically when loading instruments by selecting
Instr menu -> Add Path.

ALSO SEE
Song File Formats
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1.10 Songs / How To Set Song Compression Options

HOW TO SET SONG COMPRESSION OPTIONS
INTRODUCTION
Compressing a song before it is saved results in a significantly
smaller file size, saving disk space. There is a time and memory
overhead involved in saving and reloading the compressed file.

Compression is available in three formats: PowerPacker, SFCD and
XPK. PowerPacker uses Nico François’ popular library. SFCD -
Stephan Fuhrmann Compact Density - is designed specifically for
song compression, and uses lh.library.

XPK is not a compressor in itself; it is a means of using many
different ‘XPK-compatible’ compressors. These compressors are in
library form, stored in the LIBS:Compressors directory. A few are
supplied with OctaMED; all have four-letter names. In my
experience, the XPK SQSH library produces the most compact files in
reasonable time.

PowerPacker and XPK compression have several associated options,
available in two different windows.

STEPS
1) In the Save Options window, set the desired compression.

> Set the Compression cycle gadget to No Compression,
PowerPacker Compr., SFCD Compression or XPK Compression

2) If PowerPacker Compr. is selected, set any required options.
a) Open the PowerPacker Settings window.

> Click Settings (bottom-right)

b) Set the ‘speedup buffer’ size. Bigger buffers consume more
memory but speed up compression. Set it to Large unless you
experience memory problems.
> Set the Speedup Buffer cycle gadget

c) Set the ‘efficiency’. Better efficiency produces smaller
files but takes more time to compress. Still, I use Best on
my A500!
> Set the Efficiency cycle gadget

2) If XPK Compression is selected, set any required options.
a) Open the XPK Settings window.

> Click Settings (bottom-right)

b) Select an XPK-compatible compressor to use. Information on
all available compressors is given.
> Repeatedly click on the cycle gadget (top-left corner) to

cycle through the available compressors

c) Set the ‘efficiency’. A larger value produces smaller
files but takes more time to compress.
> Adjust the Efficiency slider

d) For compressors that also encrypt the song, set the password.
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This password must be provided when the song is reloaded.
> Type a password into the Password box

NOTES

* XPK compression requires xpkmaster.library and any desired
compressor libraries. As mentioned, some compressors are included
with OctaMED; you’re free to copy your own into the
LIBS:Compressors directory, but do work on a backup copy of the
program disk! XPK is on Fish disk 754.

* Any file that OctaMED can load can be compressed, although only
songs can be compressed from within the program. As many of the
OctaMED support files are easily compressed (e.g. MED_paths),
significant disk space savings are possible.

* Calculate the song size when compressed by clicking Packed in
the Save Options window. This actually compresses the song, so it
takes a little while.

TIPS

* The XPK NONE compressor seems useless, but by buffering saving it
actually greatly quickens song saving!

ALSO SEE

How To Save A Song

1.11 Songs / How To Attach A Message To A Song

HOW TO ATTACH A MESSAGE TO A SONG
INTRODUCTION
Using the Song Annotation window, you can attach a message to your
song. The message can be greetings, the author’s name and contact
address, comments on the song, a copyright notice, anything!

There are two types of message; both can be attached at once. One
type is only one line long, and is displayed on the screen’s title
bar when the song is reloaded.

Another type can be as long as you like! Create your message in a
text editor, save it as a text file, then load the file into
OctaMED. The message can be automatically displayed when the song
is reloaded, but only if the user has switched on Show After
Loading in the Song Annotation window.

STEPS
1) Open the Song Annotation window.

> Song menu -> Set Annotation

2) If desired, enter a one-line message to be displayed on the
screen’s title bar.
> Type in a message in the text box at the very top

3) If desired, load in a text file as a multi-line message.
> Click Load Text THEN
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> Select a text file
How?

NOTES

* Save Text saves the (long) message as a text file. Discard
Text removes the long message.

* When Show After Loading is on, after loading a song with a long
message attached, OctaMED opens the Song Annotation window to
display the message. This can be saved with settings, but not

How?
with songs. So the loader of the song has control over this

feature, not the composer of the song.

* Tab characters (ASCII code 9) shouldn’t appear in the text. If
they do, they aren’t displayed correctly.

1.12 Songs / How To Set The Save Timer

HOW TO SET THE SAVE TIMER
INTRODUCTION
Similar to the ‘automatic save’ feature of many wordprocessors, the
save timer saves the song every few minutes. The number of minutes
between saves is variable.

Frequently saving your song reduces the risk of losing your entire
song should the unthinkable happen (e.g. freak power surge just as
you’re putting the finishing touches to it).

Usually, the Save Options window is opened on every automatic save.
Optionally, the window can be opened on only the first save in
order to set saving options; subsequent saves use those options
without opening the window.

STEPS
1) Open the Save Timer window.

> Project menu -> Save Timer

2) Select the number of minutes between saves.
> Type a number into Time Between Saves (mins)

3) Select whether to open Save Options on every save or just the
first save.
> Switch on Open Save Window [every save] OR
> Switch off Open Save Window [only first save]

NOTES

* A time of 0 switches the feature off. Alternatively, use the
Active gadget.

1.13 Loading, Saving, Printing / Instruments
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HOW TO...

Load an instrument

Load a raw 16-bit sample

Save an instrument

Create a sample list

Add particular instruments to your sample list

Remove sample list information

Save part of a song as a sample
OVERVIEW

When OctaMED starts up, there are no instruments in memory:
Instruments must be loaded into memory from disk, or as part of a
song. OctaMED can load and save samples in five different file More
formats, as well as its own special instruments (synthetic sounds,
hybrids and ExtSamples).

The sample list is a list of all your instruments (not just
samples, confusingly), together with the disks and directories in
which they are stored. It provides a convenient way of loading
instruments, and helps to organise your instruments (you may
acquire thousands over time).

Using the new Mix mode, part of the song can be saved as a sample.
For example, you may create a drum beat using many instruments over
two tracks, then ‘record’ this beat as a sample and use the sample
in just one track. As a bonus, special effects such as echo can be
added to the sample!

1.14 Instruments / How To Load An Instrument

HOW TO LOAD AN INSTRUMENT
INTRODUCTION
There are two ways to load an instrument: through the Load
Instrument(s) file requester, or the Instrument Load window. The
file requester allows more than one instrument to be selected at
once; instruments are loaded into successive positions.

The Instrument Load window displays your ‘sample list’, a list of
all your instruments and their locations. Loading an instrument in
this window is a simple matter of clicking on the instrument’s
name.

OctaMED can load samples in five different file formats, as well as
its own special instruments (synthetic sounds, hybrids and
ExtSamples). See the ALSO SEE section for more details.

STEPS
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EITHER Use the Load Instrument(s) file requester.

1) Select an instrument position. If the position is already How?
occupied by an instrument, the new instrument will overwrite it.

2) Open the Load Instrument(s) file requester.
> Main Control window -> GetFile gadget OR Where?
> Instr menu -> Load Instrument(s) OR
> Sample Editor, Project menu -> Load Sample

3) Select one or more files to load.
How?

OR Use the Instrument Load window.

1) Open the Instrument Load window.
> Main Control window -> SList button OR
> Instr menu -> Load from List

2) Select an instrument position. This is easiest using the four How?
buttons at the bottom of the window. The current instrument’s
number is sandwiched between the buttons.

3) Select the directory containing the desired instrument.
> Click on a directory name in the right-hand list, using the

scroll bar if necessary

4) Load the instrument.
> Click on an instrument name in the left-hand list, using the

scroll bar if necessary

NOTES

* Upon loading, information about the instrument is displayed on
the title bar. If the instrument is a sample or synthetic sound,
its size will be shown in the form ‘n [x] bytes’. n is the number
of sample values in the instrument, x is the actual amount of
memory consumed. (n and x differ for stereo and 16-bit samples.)
The number of waveforms in a synthetic sound is also shown.

* Instead of using the Instrument Load window, you can use the full
sample list editor to load instruments. Click on an instrument in
the list, then click Load Inst. Where?

* A further method of loading instruments is to type an instrument
name into the Main Control window’s text box. Unless the
instrument appears in the sample list, type in the instrument’s
full path.

This only works if Load Instr from MainCtrl (Miscellaneous
Options) is switched on. If off, typing in a name just renames More
the current instrument.

* By default, the file requester shows the directory containing the
OctaMED program. If you have a favourite directory for
instruments, it can be shown instead. Give the disk and directory
name in the Default Directories window (Instruments text box). Where?

* If Add Path (Instr menu) is on, OctaMED adds the full path of the
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instrument after loading. This can be useful when saving songs
without instruments.

More

* The number of octaves in a loaded multi-octave sample is shown ←↩
in

the Instrument Type window. Where?

ALSO SEE
Instrument File Formats

How To Create A Sample List

1.15 Instruments / How To Load A Raw 16-Bit Sample

HOW TO LOAD A RAW 16-BIT SAMPLE
INTRODUCTION
Any truly raw sample can be loaded as 8-bit, converted to 16-bit
then further converted for use with OctaMED. By ‘truly raw’, we
mean a sample with no header whatsoever, just the sample data.
There is no way of telling the resolution of such samples, hence
the necessary 8-bit to 16-bit conversion.

Most 16-bit raw samples generated on the PC need to use the sample
editor’s Raw Sample Conversion tools after loading. Unsigned <->
Signed converts the usually ‘unsigned’ raw sample to OctaMED’s
required format, ‘signed’, and back.

Each value of a 16-bit sample takes 2 bytes of memory; use Swap
Byte Order to swap the order of each value’s pair of bytes. In
OctaMED, the ‘high’ byte must come first.

STEPS
1) Load the raw sample.

How?
2) Convert it to 16-bit. How?

3) If the sample sounds noisy and distorted, open the Sample
Editor.
> Display menu -> Sample Editor OR
> Main Control window -> Edit button

4) Try swapping the sign of its values.
> Tools menu -> Raw Sample Conversion -> Signed <-> Unsigned

5) Still noisy? Try swapping the byte order of its values.
> Tools menu -> Raw Sample Conversion -> Swap Byte Order

6) Still noisy?? Try swapping the sign of its values again. Then
you’ve tried all possible combinations!
> Tools menu -> Raw Sample Conversion -> Signed <-> Unsigned

NOTES

* OctaMED identifies a raw sample as 16-bit if the sample begins
with the 8-byte header ‘Raw16Bit’. 16-bit samples saved as Raw
using OctaMED include this header.
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* Signed <-> Unsigned also works with 8-bit samples.

1.16 Instruments / How To Save An Instrument

HOW TO SAVE AN INSTRUMENT
INTRODUCTION
Save an instrument to disk through the Instr menu or the sample
editor’s Project menu.

OctaMED can save samples in five different file formats, as well as
its own special instruments (synthetic sounds, hybrids and
ExtSamples). To save a special instrument, select any file format.
For more details, see the ALSO SEE section.

Another convenient way of saving instruments is through the Sample
More

List Editor.

STEPS
1) Decide on the file format in which to save the instrument. More

2) EITHER Save the instrument through the Instr menu.
> Select Instr menu -> Save Instrument -> chosen file format

OR Save the instrument through the sample editor.
> Select sample editor’s Project menu -> Save As chosen format

NOTES

* A Workbench icon can be saved with the sample. In the sample
editor, switch on Settings menu -> Create Icons For Samples.

ALSO SEE
Instrument File Formats

How To Add Particular Instruments To Your Sample List

1.17 Instruments / How To Create A Sample List

HOW TO CREATE A SAMPLE LIST
INTRODUCTION
The sample list is a list of all your instruments. It is not
limited to samples: Synthetic, hybrid and MIDI instruments can all
be included. The list contains the name of each instrument and its
location (disk and directory name).

You may acquire hundreds or even thousands of instruments over
time, and the sample list is a way of organising them all.
Instruments in your sample list are also very easy to load into

More
memory, through the Instrument Load window.
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If all the instruments in your song are held in the sample list,
you can save the song without its instruments. When the song is

More
later loaded, OctaMED uses the sample list to locate each

instrument and, one by one, load them from your sample disks. Think
of the amount of disk space saved by sharing instruments between
your songs in this way!

The sample list is displayed in the Sample List Editor. On the
right is a list of all directories in the list, on the left a list
of instruments in the selected directory. Select a directory or
instrument by clicking on its name. The properties of the selected
instrument are shown below the lists.

To create a sample list from scratch, open the Sample List Editor
and add your sample directories on each sample disk one by one,
removing any files that are not instruments from the list. Finally,
save the list (its usual name is MED_paths).

The Sample List Editor has its own menu strip, with Project and
Format menus.

STEPS
1) Open the Sample List Editor.

> Display menu -> Sample List Editor

2) Add a directory containing samples to the list.
> Click Add Dir (below the Directories list) THEN
> Select a directory in the requester that appears

How?
3) If the list isn’t empty, OctaMED asks you where it should add

the new directory.
> Click Top of the List [inserts before the first one] OR
> Click After Current [inserts after the current one] OR
> Click End of the List [adds after the last one]

4) OctaMED now loads the names of all files in the selected
directory. If some of the files aren’t instruments, remove them
from the list.
> Select an instrument by clicking on its name THEN
> Click Remove (below the Instruments list)

5) Save the new list.
> Click Save List (below the Directories list) THEN
> If necessary, select a file in the requester. Usually, save

under the default name.

NOTES

* All instrument properties in the Instrument Properties window can More
be set in the sample list. When an instrument is loaded through
the list, its properties are set automatically. When adding
complete directories, you must set the properties manually.

* For statistics on your sample list, select Project menu ->
Statistics. The most interesting is probably the total number of
samples in your list.
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* Usually, the sample list is saved as ‘MED_paths’ in the directory
containing the OctaMED program (PROGDIR:). This file is
automatically loaded when OctaMED starts up.

By choosing a different name, you can define several sample
lists. To load one of these lists, select Project menu -> Load
List. You can choose to add the new list to the end of the old
list, or replace the old list altogether.

* To clear the entire list, select Project menu -> Clear List.

ALSO SEE

How To Add Particular Instruments To Your Sample List

How To Remove Sample List Information

1.18 Instruments / How To Add Particular Instruments To Your Sample List

HOW TO ADD PARTICULAR INSTRUMENTS TO YOUR SAMPLE LIST
INTRODUCTION
The sample list is a list of all your instruments. It is not
limited to samples: Synthetic, hybrid and MIDI instruments can all
be included. The list contains the name of each instrument and its
location (disk and directory name).

One way to add information to your sample list is to add whole
directories containing instruments: Directory names and names of
instruments in those directories are stored in the list. Another
way is to add instruments individually. One advantage of this is
that instrument properties are included. Instruments to be added
must already be in memory, in your song.

Instruments can be added to the list and saved in the selected
directory at the same time. You can set the file format of the
saved instrument in the Sample List Editor’s Format menu.

Instead of adding a single instrument to the list, you can add and
save all instruments in your song to a particular directory. This
is great for ‘ripping’ all the instruments out of other people’s
songs! The properties of all instruments are included.

STEPS

EITHER Add a single instrument.

1) Select the instrument to be added. How?

2) Open the Sample List Editor.
> Display menu -> Sample List Editor

3) Select the directory to add the instrument to.
> Click on a directory in the list

4) EITHER Add the instrument to the directory both in the list and



OctaMED 18 / 26

on disk. In other words, add and save the instrument to disk.
a) If necessary, select the file format. More

> Select a format in Format menu -> 8-Bit Samples OR
> Select a format in Format menu -> 16-Bit Samples

b) Add and save the instrument to disk.
> Click Save Ins (below the Instruments list)

OR Add the instrument to the directory without saving it to
disk.

> Click Add (below the Instruments list)

OR Add all instruments in your song.

1) Open the Sample List Editor.
> Display menu -> Sample List Editor

2) Select the directory to add the instruments to.
> Click on a directory in the list

3) If necessary, select the file format. More
> Select a format in Format menu -> 8-Bit Samples OR
> Select a format in Format menu -> 16-Bit Samples

4) Add and save all the instruments in the selected directory.
> Click Save All Insts

NOTES

* Your favourite 8-bit and 16-bit file format is saved with
More
settings.

ALSO SEE

How To Create A Sample List

How To Remove Sample List Information

1.19 Instruments / How To Remove Sample List Information

HOW TO REMOVE SAMPLE LIST INFORMATION
INTRODUCTION
The sample list is a list of all your instruments. It is not
limited to samples: Synthetic, hybrid and MIDI instruments can all
be included. The list contains the name of each instrument and its
location (disk and directory name).

You can remove whole directories or individual instruments from
your list, if they no longer exist or are relevant. You can also
completely remove an instrument, both in the list and on disk; be
careful with this one!

STEPS
1) Open the Sample List Editor.

> Display menu -> Sample List Editor
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2) EITHER Remove a directory from the list.
a) Select a directory.

> Click on its name in the Directories list

b) Remove the selected directory from the list.
> Click Remove Dir (below the Directories list)

OR Remove an instrument.
a) Select the directory containing the instrument.

> Click on its name in the Directories list

b) Select an instrument.
> Click on its name in the Instruments list

c) EITHER Remove the selected instrument from the list.
> Click Remove (below the Instruments list)

OR Remove the instrument from the list AND delete it on disk.
> Click Del Ins (below the Instruments list)

* Warning: There is no confirmation requester!

ALSO SEE

How To Create A Sample List

How To Add Particular Instruments To Your Sample List

How To Delete One Or More Files

1.20 Instruments / How To Save Part Of A Song As A Sample

HOW TO SAVE PART OF A SONG AS A SAMPLE
INTRODUCTION
The new Mix mode can play music through a selection of ‘output
devices’, including your Amiga and 16-bit soundboards. It can also
play to disk! This feature, called ‘direct-to-disk recording’,
allows part or all of a song to be saved as a sample.

If many seconds of music are recorded, the sample may be pretty
long! Still, direct-to-disk recording has many uses. You can
construct a drum beat in a Tracker editor block over several
tracks, then use this feature to ‘sample’ the drum beat. The
resulting sample can then be used on a single track. In a 4-channel
environment, every track is vital!

Alternatively, store an entire song on your hard drive as a sample,
then use the Play16 program to play it using very little processor
time. Or use the sample to record a song directly to your hard
drive or a CD, without any unnecessary analogue-to-digital-and-back
conversions. After all, the sample is a digital image of the song.

This how-to is based on section 10.5 of the printed manual, but it
specifically shows you how to save part of a block (e.g. a drum
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beat) as a sample. To save the whole song, jump straight to step 4.

STEPS
1) Select the appropriate block. How?

2) Set up the block for recording.
a) Set where the recording should stop (e.g. at the end of the

drum beat). To do this, add an 0FFE player command on the How?
last line of the part to be recorded.

b) Switch off any tracks that are not to be recorded. How?

c) Move to the first line of the part to be recorded. If it’s How?
the first line of the block, you needn’t do this - just
remember to click Play Block instead of Cont Block later on.

3) If the recorded sample will be loaded back into OctaMED for use
in a song, decide which note should be used to play the sample
at its correct pitch, and determine the frequency of this note.
The higher the note, the better the sound quality, but the
longer the recorded sample.
a) Open the Sample Editor.

> Display menu -> Sample Editor OR
> Main Control window -> Edit button

b) Choose the note used to play the sample.
> Set the pitch box beside Pitch (bottom-right) How?

c) Make a note of the frequency displayed beside the pitch box.
Call the number F.

d) Close the Sample Editor.
> Click its close gadget OR
> Select Project menu -> Exit Sample Editor

4) To record the whole song, enter an 0FFE player command at the How?
very last line of the very last block played in the song.

5) If necessary, change to Mix mode.
a) Open the Song Options window.

> Songs menu -> Set Options

b) Holding down a Shift key, click 1-64 Ch Mixing. (Holding down
Shift transposes all notes in your song up two octaves.)

c) Close the Song Options window.
> Click Exit

6) Set necessary Mix mode settings.
a) Open the Mixing Settings window.

> Settings menu -> Mixing Settings

b) Choose to record an 8-bit or 16-bit sample. The Amiga cannot
currently play 16-bit samples, but 16-bit soundboards can. More
> Click Disk 8-bit (top-left) OR
> Click Disk 16-bit
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c) Choose to record a mono or a stereo sample. For use in a
song, it should normally be mono.
> Switch off Stereo [record in mono] OR
> Switch on Stereo [record in stereo]

d) Switch smoothing on (recommended).
> Switch on Smoothing (top-right)

e) Set the recording frequency. If you followed step 3 above,
set the frequency to F. Otherwise, set any frequency. The
higher, the better the quality but the longer the sample.
> Type a number into the Requested box OR
> Adjust the Mixing Frequency slider

f) Set the number of channels to the maximum number of tracks
used in the recorded part of your song. For example, if notes
appear anywhere on track 5, set it to 6. It’s best if your
song uses consecutive tracks from track 0.
> Adjust the Max Channels slider. The lower, the better

g) Set a large mix buffer size.
> Set Mix Buffer Size to, say, 30000

h) Set other desired settings: Volume Adjust, Track Panning and
Effects. Echo (in the Effects window) is especially
effective. See sections 10.6 and 10.7 of the printed manual.

i) Close the window.
> Click Exit

7) Start recording.
> Click Play Song [to record the whole song] OR
> Click Cont Block [to record part of a block] OR
> Click Play Block [to record part of a block from its start]

8) In the file requester, select a name for the recorded sample.
How?

In the next requester, select a file format for the sample. ←↩
More

(Different formats are available for 8-bit and 16-bit samples,
and mono and stereo samples.)

9) When recorded, switch off Mix mode (unless your song uses Mix
mode), and if necessary, load the instrument into memory to use

How?
in your song.

> Song menu -> Set Options
> Holding down a Shift key, click on your song’s channel mode.

(The song’s notes are transposed back down 2 octaves.)

* If your song uses Mix mode, your usual output device will have
been re-selected.

NOTES

* If you followed every step, congratulations on completing the
longest how-to in these help pages!
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* The volume of the produced sample is usually not very loud, so
increase Volume Adjust to (say) 125 - this may cause distortion,
so experiment! In hindsight, increase the volume to the maximum How?
possible without distortion in the Change Volume window.

1.21 Loading, Saving, Printing / Settings

HOW TO...

Load settings

Save settings
OVERVIEW

OctaMED is a ‘configurable’ program, in that you can set it up just
how you like it. No two people’s ideal ‘configuration’ is likely to
be the same.

The configuration is a number of options throughout the program
which can be ‘saved with settings’, or stored in a settings file.
You can save as many different settings files as you wish, but one
particular file is automatically loaded when OctaMED starts up.
It’s called Soundstudio.config, and must be placed in the directory
containing the OctaMED program (PROGDIR:).

You can set different combinations of options for a variety of
scenarios, and save them in different settings files. Any of these
settings files can be loaded into OctaMED at any point. You might
have one setting file for MIDI use, another for playing in Mix
mode, another that uses a different screen mode or font, and so on.

The precise options saved with settings are listed in the Brief
guide appendix The Settings File . If you switch on
Show Changed Settings (Miscellaneous Options window), however, you
can test whether or not a particular option is saved with settings.

1.22 Settings / How To Load Settings

HOW TO LOAD SETTINGS
INTRODUCTION
Select and load a settings file through the Settings menu. After
loading, the options in the file are set. This involves closing and
reopening the entire screen, in case there are any changes to the
screen mode or font.

STEPS
1) Select a settings file to load, and load it.

> Settings menu -> Load Settings

ALSO SEE

How To Save Settings
The Settings File
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1.23 Settings / How To Save Settings

HOW TO SAVE SETTINGS
INTRODUCTION
Save a settings file through the Settings menu. Usually, you’ll
want to save under the ‘default’ name, PROGDIR:Soundstudio.config,
so that the saved options are set whenever OctaMED starts up. A
separate menu item is provided for this purpose.

The precise options saved with settings are listed in the Brief
guide appendix The Settings File .

STEPS
1) EITHER Save settings under the usual name.

> Select Settings menu -> Save Settings

OR Select any name and save settings under that name.
> Select Settings menu -> Save Settings As

NOTES

* Important: The windows currently open are saved with settings.
These windows are reopened when OctaMED loads the settings (often
on startup). So when you save settings, be careful which windows
are open!

* To test whether individual options are saved with settings,
switch on Miscellaneous Options window -> Show Changed Settings,
then alter the value of an option (e.g. switch it off or set it
to 2).

If the option is saved with settings, an (S) appears at the end
of the message on the screen’s title bar. The ARexx name of the
option is also given.

ALSO SEE

How To Load Settings

1.24 Loading, Saving, Printing / Printing A Song

HOW TO...

Print a song in Tracker editor format

Print a song in standard notation
OVERVIEW

If you have a printer, you can print out your masterpiece in
Tracker editor format or standard musical notation. Printing in
standard musical notation is the more useful, as this can be used
as sheet music for playing on a real instrument.

Both printing methods ask you which part of the song to print. In
Tracker editor format, you supply starting and ending block
numbers. In standard notation, you specify starting and ending
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‘displayfuls’ of measures. The number of measures per displayful
can be set. How?

As printing in standard notation is more useful, it is the most
flexible. Any settings applying to the notation editor display, set
in the Notation Display Setup window, also apply to printing. In More
addition, you can set the ‘resolution’ - print quality - of the
printout. The actual quality of print depends on your PrinterGfx
Preferences settings and, of course, on your printer.

A particularly useful feature of Tracker editor printing, however,
is the ‘print header’. Printed just before your song, the header
contains useful song information, such as a list of its instruments
and their properties, track volumes and playing sequence. The
header is not available with Print Notation.

1.25 Printing A Song / How To Print A Song In Tracker Editor Format

HOW TO PRINT A SONG IN TRACKER EDITOR FORMAT
INTRODUCTION
Use the Print Options window to print a song in the way it’s shown
in the Tracker editor. The whole song or a range of blocks can be
printed, as plain text. Highlighted lines are printed in bold. More

Optionally, you can ‘print to a file’. This means saving to disk
the information that would normally be printed. You can load such a
file into a text viewer or editor.

A useful feature of printing in Tracker editor format is the ‘print
header’. Printed just before your song, the header contains useful
song information (see notes).

STEPS
1) Open the Print Options window.

> Project menu -> Print

2) If desired, save the printout in a file instead of printing it.
> Type a filename into the Output File text box OR
> Click on the GetFile gadget beside the text box, and select a

file in the requester
How?

3) Set the blocks to be printed. All blocks, the current block or ←↩
a

range of blocks (e.g. numbers 8 to 11) can be printed.
> Click All Blocks OR
> Click Current Block OR
> Set the Start Block and End Block appropriately

4) If desired, choose not to print the blocks, only the header.
> Set the cycle gadget below Options to Don’t Print Blocks

5) If desired, choose not to print the header. If Don’t Print
Blocks is also set, nothing will be printed!
> Switch off Print Header (bottom-right)
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6) If desired, choose not to print a formfeed after the header and
between blocks. The formfeed ensures that each block begins on a
new page.
> Switch off Form Feed (bottom-right)

7) Print the song.
> Click Print

NOTES

* Be careful: Once you’ve started printing, there’s no way to stop
it! (unlike printing in standard notation)

* The print header includes a list of instruments and their
properties, track volumes, playing sequence(s), section list,
song tempo and play transpose.

* OctaMED prints by sending information to the PRT: device. Other
possible devices are PAR: and SER:, which may be set in the
Output File box.

1.26 Printing A Song / How To Print A Song In Standard Notation

HOW TO PRINT A SONG IN STANDARD NOTATION
INTRODUCTION
This how-to assumes that you’re familiar with the notation editor. More

Through the notation editor’s Print Notation window, OctaMED can
print a song in standard musical notation. The printout can be used
as ‘sheet music’ to be played on a musical instrument. Temporarily
removed in OctaMED V6, this feature is now better than ever!

The entire song or just part of the song can be printed. While
printing in Tracker editor format requires the starting and ending
block numbers, printing in standard notation requires starting and
ending ‘displayfuls’ of measures. The number of measures per
displayful is set in the Notation Display Setup window.

In fact, all options in Notation Display Setup affect printing. You More
can choose how wide staffs should be, whether or not to print staff
names, and whether to print blocks in numerical order or in the
order in which they appear in the playing sequence.

So the logic behind printing is: What you see on the screen is what
you get on the page. The only respect in which the display and the
printout differ is that Space Above and Space Below (Staff Setup More
window) are both ignored. OctaMED works out the spacing between
staffs so that notes are never ‘clipped’.

In the Print Notation window, as well as stating the part of the
song to be printed, you must select the ‘print resolution’: the
print quality. 1$\times$ resolution uses the standard Amiga font, while
other resolutions use the higher-quality Compugraphic font. Higher
resolutions, however, take more time and require more memory.

Print quality also depends on the PrinterGfx Preferences settings
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(on your Workbench disk), and, of course, on the type of printer
you own. If you have a dot matrix printer, select 1$\times$. Higher
resolutions are recommended for bubble jet, ink jet or laser
printers.

STEPS
1) Set any required options in the Notation Display Setup window.

> Windows menu -> Display Setup
> Set the options as required

2) Open the Print Notation window.
> Notation editor’s Project menu -> Print

3) Set the part of the song to print, in ‘displayfuls’ of measures.
A displayful is whatever is displayed in the notation editor in
one go. The Current buttons set Start or End to the current
displayful. When you open the window, Start and End are set up
to print the entire song.
> Type a number into Start OR click Current THEN
> Type a number into End OR click Current

4) Set the print ‘resolution’ (quality).
> Set Resolution to 1$\times$ (Std Font) or 2$\times$, 4$\times$ or 8$\times$ ( ←↩

CG Font)

5) Print the song.
> Click Print

6) If necessary, interrupt the printing.
> Click Stop in the requester which appears

NOTES

* When selecting the resolution, it is important to consider your
available memory. 2$\times$, 4$\times$ and 8$\times$ require 4, 16 and 64 times ←↩

more
memory than 1$\times$! OctaMED uses a print buffer, the size of which is
determined by the resolution, the number of staffs and the staff
width. Also, the Compugraphic font takes more memory than the
standard font.

The important setting in the PrinterGfx program is Density.
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